Freightliner columbia ecm problem (2024)

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by bruce25, May 19, 2017.

Page 1 of 3

  1. May 19, 2017#1

    bruce25Light Load Member

    143
    86
    Apr 16, 2014
    0
    Check engine and engine protect came up truck shuts down it will crank but wont start cluster displays 0 volts but the truck has power inside

    No eng
    Sid 254 fail 07
    Cdu 219
    Fail 04
    Sid 010 fail 02

    I have tried everything checked fuses pdm box battery fuses. Checked cables i am oit of ideas is the ecm dead?

    bruce25,May 19, 2017

    bruce25,May 19, 2017

    #1

  2. Freightliner columbia ecm problem (2)

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. May 20, 2017#2

    xsetraRoad Train Member

    4,958
    6,659
    Aug 21, 2011
    0
    What motor. What year?

    xsetra,May 20, 2017

    xsetra,May 20, 2017

    #2

  4. May 21, 2017#4

    Series 60 12.7 year 2003 i checked harness pins for volts and the big pin close to cab has 4 pins with 12 volts and a 5 large pin cable above it has two pins with 12 volts. So ecm is getting power but dash is not reading anything from it shows 0 volts no eng with alot of faults and also check eng and protect is constantly on once you turn the key. Also dash shows option with EC with lines across seems like there is nothing coming out of ecm. I took the ecm off opened it saw sign of water condensation

    bruce25,May 21, 2017

    bruce25,May 21, 2017

    #4

    Oldironfan Thanks this.

  5. May 21, 2017#4

    bahaRoad Train Member

    4,137
    2,834
    Jul 25, 2013
    ga
    0
    Go behind drivers seat and find rear fuse panel, pull all and clean corr. off all find the water leak and fix all seams above breaker panel with auto body sealer, has the wiring harness from L side of firewall to motor ever been replaced?

    baha,May 21, 2017

    baha,May 21, 2017

    #4

    Oldironfan Thanks this.

  6. May 21, 2017#5

    Fast Track MechanicBobtail Member

    13
    5
    May 16, 2017
    0
    Cant find your fault codes on any of these links. see if you have better luck
    Fault Code Web Links

    there is an abs fault code for sid 254 fail 07 but that wont stop your truck from starting
    I found this helpful answer from a technician on JustAnswer.com

    TRS or SRS sensor can prevent engine starting
    Sounds silly but no fuel will prevent engine from starting. make sure the fuel pickup in the tank isnt broken
    coolant temp, coolant level, oil pressure will shut you down. unplug those sensors and see if it will start.(turns the code into open circuit and therefore a check engine not a stop engine fault code. obviously if it starts switch it straight off incase you do have an oil pressure problem not just faulty wiring or sensor)
    make sure you have pwr and earth to ecm see attached picsFreightliner columbia ecm problem (7) Freightliner columbia ecm problem (8)

    Fast Track Mechanic,May 21, 2017

    Fast Track Mechanic,May 21, 2017

    #5

    Oldironfan Thanks this.

  7. May 21, 2017#7

    bruce25Light Load Member

    143
    86
    Apr 16, 2014
    0
    You mean panel on the left side of the driver seat? If so i checked it and it looks good. Harness has never been to my knowledge not sure if it was before i purchased it. I did check the harness it looks hood i saw no broken wires pins on the ecm wired to get 12v

    bruce25,May 21, 2017

    bruce25,May 21, 2017

    #7

    Oldironfan Thanks this.

  8. May 21, 2017#7

    bruce25Light Load Member

    143
    86
    Apr 16, 2014
    0

    bruce25,May 21, 2017

    bruce25,May 21, 2017

    #7

  9. May 21, 2017#8

    bahaRoad Train Member

    4,137
    2,834
    Jul 25, 2013
    ga
    0
    Did you pull all the relays inside the fuse box in the sleeper? it may be on the other side of pass. door but the relays having green on the prongs can do what you are seeing?

    baha,May 21, 2017

    baha,May 21, 2017

    #8

  10. May 21, 2017#10

    bruce25Light Load Member

    143
    86
    Apr 16, 2014
    0
    I pulled the relays in the fuse box that sits under the dash on the pass side and i didnt see any corrosion. I can recheck again and see if i missed anything. Which relay is for ecm i checked ecm fuse and its good

    bruce25,May 21, 2017

    bruce25,May 21, 2017

    #10

  11. May 21, 2017#10

    kemosabi49Trucker Forum STAFFStaff Member

    10,063
    41,825
    Jan 13, 2013
    SW Arkansas
    0
    Had that happen to me on a '03. Ended up being the small wire that goes to the batteries was not connected. Had broke and fell behind the batteries.

    kemosabi49,May 21, 2017

    kemosabi49,May 21, 2017

    #10

    Oldironfan Thanks this.

  • Freightliner columbia ecm problem (14)

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Page 1 of 3

    Freightliner columbia ecm problem (2024)
    Top Articles
    Latest Posts
    Article information

    Author: Manual Maggio

    Last Updated:

    Views: 6334

    Rating: 4.9 / 5 (49 voted)

    Reviews: 80% of readers found this page helpful

    Author information

    Name: Manual Maggio

    Birthday: 1998-01-20

    Address: 359 Kelvin Stream, Lake Eldonview, MT 33517-1242

    Phone: +577037762465

    Job: Product Hospitality Supervisor

    Hobby: Gardening, Web surfing, Video gaming, Amateur radio, Flag Football, Reading, Table tennis

    Introduction: My name is Manual Maggio, I am a thankful, tender, adventurous, delightful, fantastic, proud, graceful person who loves writing and wants to share my knowledge and understanding with you.